User Interface Access in EMEA1
Incident Report for Own Company
Resolved
This incident has been resolved.
Posted Feb 27, 2020 - 06:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2020 - 22:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 26, 2020 - 22:13 UTC
Investigating
We’re investigating reports about difficulty in accessing the OwnBackup user interface from the web.
Our engineering team is currently looking into the issue and we will update shortly.
Posted Feb 26, 2020 - 22:07 UTC
This incident affected: EMEA1 (User Access).