Failing Services in <HIPAA1>
Incident Report for Own Company
Resolved
This incident has been resolved.
Posted May 31, 2021 - 14:50 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 31, 2021 - 13:35 UTC
Identified
We’re investigating reports of a problem that might be affecting multiple services functionality.
Our engineering team is currently looking into the issue and we will update shortly.
Posted May 31, 2021 - 13:34 UTC
This incident affected: HIPAA1 (Automatic Backups).