Failing Backup services in few regions
Incident Report for OwnBackup
Resolved
This incident has been resolved.
Posted May 17, 2021 - 13:59 UTC
Update
We are continuing to investigate this issue.
Posted May 17, 2021 - 13:57 UTC
Update
We are continuing to investigate this issue.
Posted May 17, 2021 - 09:24 UTC
Investigating
We are experiencing a momentary Backup Service issue.
Several backups failed completing successfully.
OwnBackup has taken remediation steps to resolve the issue.
Posted May 17, 2021 - 09:22 UTC
This incident affected: App1 (Automatic Backups), HIPAA1 (Automatic Backups), and EMEA1 (Automatic Backups).