Metadata backups - performance
Incident Report for Own Company
Resolved
This incident has been resolved.
Posted Dec 12, 2019 - 06:50 UTC
Investigating
Metadata backups are taking longer than expected due to suspected communication issue with salesforce. The issue is currently being investigated with the Salesforce support team.
Posted Nov 11, 2019 - 07:35 UTC